ParhainHinta.fi
Zyxel GS1915-8, Hallittu, L2, Gigabit Ethernet (10/100/1000), Täysin kaksipuolinen
ZyXEL Communications

Zyxel GS1915-8, Hallittu, L2, Gigabit Ethernet (10/100/1000), Täysin kaksipuolinen

Compare this product across 7 stores. Lowest product price now 69,90 €.

Latest price observation: 30/09/2026, 08.01

Edullinen pilviohjattu 8-porttinen kytkin

In stock
Lowest product price

69,90 €

Multitronic

Lowest tracked price: 69,90 €

See all 7 offers

Zyxel GS1915-8, Hallittu, L2, Gigabit Ethernet (10/100/1000), Täysin kaksipuolinen price trend

Price history · 27 tracked days

The observed product price has dropped 4 % during the tracked period.

Price history shows the lowest observed product price for each day. Delivery costs are not included.

Lowest observed product price

69,90 €

Average product price

72,85 €

Highest observed product price

73,09 €

Compare prices

The comparison uses the product price. Check delivery costs and terms on the merchant site.

StoreProduct priceAvailabilityUpdated
1Multitronic69,90 €30-day observed low: 69,90 €All-time observed low: 69,90 €Unknown29/09/2026, 16.49Go to store
2CS Megastore73,09 €30-day observed low: 73,09 €All-time observed low: 73,09 €In stock03/09/2026, 13.15Go to store
3Multitronic73,90 €30-day observed low: 73,90 €All-time observed low: 73,90 €In stock03/09/2026, 13.15Go to store
4Hobbyhall.fi77,08 €30-day observed low: 77,08 €All-time observed low: 77,08 €In stock30/09/2026, 07.07Go to store
5Proshop79,28 €30-day observed low: 79,28 €All-time observed low: 79,28 €Unknown24/09/2026, 05.44Go to store
6Dustin81,58 €30-day observed low: 81,58 €All-time observed low: 81,58 €Unknown28/09/2026, 03.41Go to store
7Verkkokauppa.com82,99 €30-day observed low: 82,99 €All-time observed low: 82,99 €Unknown30/09/2026, 08.01Go to store
Showing 7 / 7 offers

The 30-day and all-time lows are ParhainHinta.fi observations for that merchant. They are not, by themselves, the merchant's statutory reference price for discount advertising.

Specifications

10G support
No
AC input frequency
50 - 60 Hz
AC input voltage
220 - 240 V
Auto MDI/MDI-X
Yes
Basic switching RJ-45 Ethernet ports quantity
8
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Broadcast storm control
Yes
Cables included
AC
Certification
CE, FCC, C-Tick, Class A, Class B, BSMI CNS13438
Copper ethernet cabling technology
10BASE-T, 100BASE-TX, 1000BASE-T
Depth
104 mm
Electromagnetic compatibility
LVD EN60950-1, BSMI CNS14336-1
Flow control support
Yes
Forwarding rate
11.9 Mpps
Full duplex
Yes
Gigabit Ethernet (copper) ports quantity
8
Harmonized System (HS) code
85176990
Heat dissipation
16.03 BTU/h
Height
27 mm
IGMP snooping
Yes
Installed SFP modules quantity
0
Installed SFP+ modules quantity
0
Jumbo frames
9000
Jumbo frames support
Yes
LED indicators
Yes
MAC address filtering
Yes
MAC address table
8000 entries
Mallinumero
GS19158EU0101F
Management protocols
SNMP v1,v2,v3, RMON (1,2,3,9)
Manual
Yes
Mean time between failures (MTBF)
1144461 h
MIB support
RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493
Multicast support
Yes
Networking standards
IEEE 802.1Q, IEEE 802.1p, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Number of VLANs
8
Operating relative humidity (H-H)
10 - 95%
Operating temperature (T-T)
0 - 40 °C
Package depth
227 mm
Package height
64 mm
Package weight
1.1 kg
Package width
302 mm
Packet buffer memory
0.525 MB
Power connector
AC-in jack
Power consumption (max)
4.7 W
Power over Ethernet (PoE)
No
Power source
AC
Product colour
Black
Quality of Service (QoS) support
Yes
Quick start guide
Yes
Rate limiting
Yes
SSH/SSL support
Yes
Storage relative humidity (H-H)
10 - 95%
Storage temperature (T-T)
-40 - 70 °C
Switch layer
L2
Switch type
Managed
Switching capacity
16 Gbit/s
System event log
Yes
User guide
Yes
VLAN support
Yes
Web-based management
Yes
Weight
620 g
Width
250 mm
EAN / GTIN
4718937621897

Similar products