
Zyxel GS1920-48V2-EU0101F - Älykäs hallittava Gigabit Ethernet -kytkin, Musta
Compare this product across 6 stores. Lowest product price now 381,90 €.
Latest price observation: 30/09/2026, 14.10
Älykytkin, jossa on 48 porttia, IGMP ja elinikäinen takuu
381,90 €
Multitronic
Lowest tracked price: 381,90 €
Zyxel GS1920-48V2-EU0101F - Älykäs hallittava Gigabit Ethernet -kytkin, Musta price trend
Price history · 27 tracked daysThe observed product price has dropped 2 % during the tracked period.
Price history shows the lowest observed product price for each day. Delivery costs are not included.
Lowest observed product price
381,90 €
Average product price
390,23 €
Highest observed product price
390,90 €
Compare prices
The comparison uses the product price. Check delivery costs and terms on the merchant site.
| Store | Product price | Availability | Updated | ||
|---|---|---|---|---|---|
| 1 | Multitronic | 381,90 €30-day observed low: 381,90 €All-time observed low: 381,90 € | Unknown | 29/09/2026, 16.49 | Go to store |
| 2 | Multitronic | 390,90 €30-day observed low: 390,90 €All-time observed low: 390,90 € | In stock | 03/09/2026, 01.44 | Go to store |
| 3 | Proshop | 403,67 €30-day observed low: 400,99 €All-time observed low: 400,99 € | Unknown | 25/09/2026, 11.45 | Go to store |
| 4 | Verkkokauppa.com | 427,00 €30-day observed low: 427,00 €All-time observed low: 427,00 € | Unknown | 30/09/2026, 14.10 | Go to store |
| 5 | Dustin | 446,78 €30-day observed low: 446,78 €All-time observed low: 446,78 € | Unknown | 28/09/2026, 03.38 | Go to store |
| 6 | Teknikproffset FI | 491,99 €30-day observed low: 490,99 €All-time observed low: 490,99 € | Unknown | 14/09/2026, 11.46 | Go to store |
The 30-day and all-time lows are ParhainHinta.fi observations for that merchant. They are not, by themselves, the merchant's statutory reference price for discount advertising.
Specifications
- 10G support
- No
- AC input frequency
- 50 - 60 Hz
- AC input voltage
- 100 - 240 V
- Access Control List (ACL)
- Yes
- ARP inspection
- Yes
- Authentication
- Guest VLAN, Port-based authentication
- Authentication type
- IEEE 802.1x, RADIUS
- Basic switching RJ-45 Ethernet ports quantity
- 44
- Basic switching RJ-45 Ethernet ports type
- Gigabit Ethernet (10/100/1000)
- Cables included
- AC
- Certification
- RoHS
- Combo SFP ports quantity
- 4
- Copper ethernet cabling technology
- 100BASE-TX, 1000BASE-T
- CPU defense
- Yes
- Depth
- 220 mm
- DHCP features
- DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client
- Electromagnetic compatibility
- FCC 15 A, CE A, BSMI EMC
- Fiber ethernet cabling technology
- 1000BASE-X
- Fiber optic connector
- SFP
- Flash memory
- 32 MB
- Flow control support
- Yes
- Forwarding rate
- 74 Mpps
- Harmonized System (HS) code
- 85176990
- Heat dissipation
- 125.83 BTU/h
- Height
- 44.5 mm
- IGMP snooping
- Yes
- Installed SFP modules quantity
- 0
- Installed SFP+ modules quantity
- 0
- Internal memory
- 256 MB
- IP-MAC-Port binding
- Yes
- LED indicators
- Yes
- MAC address filtering
- Yes
- MAC address table
- 16000 entries
- Mallinumero
- GS192048V2EU0101F
- Mean time between failures (MTBF)
- 672235 h
- MIB support
- RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
- Multicast support
- Yes
- Networking standards
- IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
- Noise level
- 26 dB
- Operating relative humidity (H-H)
- 10 - 95%
- Operating temperature (T-T)
- 0 - 50 °C
- Package depth
- 289 mm
- Package height
- 90 mm
- Package weight
- 3.97 kg
- Package width
- 496 mm
- Packet buffer memory
- 1.5 MB
- Password protection
- Yes
- Power consumption (max)
- 36.9 W
- Power over Ethernet (PoE)
- No
- Product colour
- Black
- Quality of Service (QoS) support
- Yes
- Queue scheduling algorithms
- SPQ, WFQ, Weighted Round Robin (WRR)
- Rack mount kit
- Yes
- Rack mounting
- Yes
- Rate limiting
- Yes
- Safety
- LVD, BSMI
- Security algorithms
- 802.1x RADIUS, SNMP, SNMPv3
- SFP module slots quantity
- 2
- Spanning tree protocol
- Yes
- Storage relative humidity (H-H)
- 10 - 95%
- Storage temperature (T-T)
- -40 - 70 °C
- Switch type
- Managed
- Switching capacity
- 100 Gbit/s
- System event log
- Yes
- Väri
- Black
- Virtual LAN features
- Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
- VLAN support
- Yes
- Weight
- 2.8 kg
- Width
- 440 mm
- EAN / GTIN
- 4718937601899
