ParhainHinta.fi
Zyxel Nebula Gs1920-24v2 24g 4sfp Switch
ZyXEL Communications

Zyxel Nebula Gs1920-24v2 24g 4sfp Switch

Compare this product across 7 stores. Lowest product price now 222,57 €.

Latest price observation: 30/09/2026, 14.10

Älykytkin, jossa on 24 porttia, IGMP ja elinikäinen takuu

In stock
Lowest product price

222,57 €

Proshop

Lowest tracked price: 222,57 €

See all 7 offers

Zyxel Nebula Gs1920-24v2 24g 4sfp Switch price trend

Price history · 27 tracked days

The observed product price has dropped 4 % during the tracked period.

Price history shows the lowest observed product price for each day. Delivery costs are not included.

Lowest observed product price

222,57 €

Average product price

230,13 €

Highest observed product price

230,90 €

Compare prices

The comparison uses the product price. Check delivery costs and terms on the merchant site.

StoreProduct priceAvailabilityUpdated
1Proshop222,57 €30-day observed low: 222,57 €All-time observed low: 222,57 €Unknown29/09/2026, 03.25Go to store
2Multitronic230,90 €30-day observed low: 230,90 €All-time observed low: 230,90 €In stock03/09/2026, 23.33Go to store
3Multitronic230,90 €30-day observed low: 230,90 €All-time observed low: 230,90 €Unknown29/09/2026, 16.49Go to store
4Verkkokauppa.com230,99 €30-day observed low: 230,99 €All-time observed low: 230,99 €Unknown30/09/2026, 14.10Go to store
5CS Megastore241,35 €30-day observed low: 241,35 €All-time observed low: 241,35 €In stock03/09/2026, 23.33Go to store
6Dustin249,75 €30-day observed low: 249,75 €All-time observed low: 249,75 €Unknown28/09/2026, 03.38Go to store
7Teknikproffset FI347,99 €30-day observed low: 346,99 €All-time observed low: 346,99 €Unknown14/09/2026, 11.46Go to store
Showing 7 / 7 offers

The 30-day and all-time lows are ParhainHinta.fi observations for that merchant. They are not, by themselves, the merchant's statutory reference price for discount advertising.

Specifications

10G support
No
AC input frequency
50 - 60 Hz
AC input voltage
100 - 240 V
Access Control List (ACL)
Yes
ARP inspection
Yes
Authentication
Guest VLAN, Port-based authentication
Authentication type
IEEE 802.1x, RADIUS
Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Cables included
AC
Certification
RoHS
Combo SFP ports quantity
4
Copper ethernet cabling technology
100BASE-TX, 1000BASE-T
CPU defense
Yes
Depth
131 mm
DHCP features
DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client
Electromagnetic compatibility
FCC 15 A, CE A, BSMI EMC
Fiber ethernet cabling technology
1000BASE-X
Fiber optic connector
SFP
Flash memory
32 MB
Flow control support
Yes
Forwarding rate
42 Mpps
Harmonized System (HS) code
85176990
Heat dissipation
76.73 BTU/h
Height
44 mm
IGMP snooping
Yes
Installed SFP modules quantity
0
Installed SFP+ modules quantity
0
Internal memory
256 MB
IP-MAC-Port binding
Yes
LED indicators
Yes
MAC address filtering
Yes
MAC address table
16000 entries
Mallinumero
GS192024V2EU0101F
Mean time between failures (MTBF)
911301 h
MIB support
RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
Multicast support
Yes
Networking standards
IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
Noise level
0 dB
Operating relative humidity (H-H)
10 - 95%
Operating temperature (T-T)
0 - 50 °C
Package depth
214 mm
Package height
79 mm
Package weight
2.91 kg
Package width
558 mm
Packet buffer memory
1.5 MB
Password protection
Yes
Power consumption (max)
22.5 W
Power over Ethernet (PoE)
No
Product colour
Black
Quality of Service (QoS) support
Yes
Queue scheduling algorithms
SPQ, WFQ, Weighted Round Robin (WRR)
Rack mount kit
Yes
Rack mounting
Yes
Rate limiting
Yes
Safety
LVD, BSMI
Security algorithms
802.1x RADIUS, SNMP, SNMPv3
Spanning tree protocol
Yes
Storage relative humidity (H-H)
10 - 95%
Storage temperature (T-T)
-40 - 70 °C
Switch type
Managed
Switching capacity
56 Gbit/s
System event log
Yes
Virtual LAN features
Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
VLAN support
Yes
Weight
2.1 kg
Width
441 mm
EAN / GTIN
4718937601851