ParhainHinta.fi
Zyxel GS1900-24E, Hallittu, Gigabit Ethernet (10/100/1000)
ZyXEL Communications

Zyxel GS1900-24E, Hallittu, Gigabit Ethernet (10/100/1000)

Compare this product across 6 stores. Lowest product price now 99,90 €.

Latest price observation: 30/09/2026, 07.06

Kytkin, smart, 24 x 10/100/1000, telineeseen asennettava, seinään asennettava malleihin USG Flex 100

In stock
Lowest product price

99,90 €

Multitronic

Lowest tracked price: 99,90 €

See all 6 offers

Zyxel GS1900-24E, Hallittu, Gigabit Ethernet (10/100/1000) price trend

Price history · 27 tracked days

The observed product price has stayed flat during the tracked period.

Price history shows the lowest observed product price for each day. Delivery costs are not included.

Lowest observed product price

99,90 €

Average product price

99,90 €

Highest observed product price

99,90 €

Compare prices

The comparison uses the product price. Check delivery costs and terms on the merchant site.

StoreProduct priceAvailabilityUpdated
1Multitronic99,90 €30-day observed low: 99,90 €All-time observed low: 99,90 €In stock04/09/2026, 03.12Go to store
2Multitronic109,90 €30-day observed low: 109,90 €All-time observed low: 109,90 €Unknown29/09/2026, 16.49Go to store
3CS Megastore112,69 €30-day observed low: 112,69 €All-time observed low: 112,69 €In stock04/09/2026, 03.12Go to store
4Proshop112,99 €30-day observed low: 112,99 €All-time observed low: 112,99 €In stock04/09/2026, 03.12Go to store
5Hobbyhall.fi118,75 €30-day observed low: 118,75 €All-time observed low: 118,75 €In stock30/09/2026, 07.06Go to store
6Dustin119,22 €30-day observed low: 119,22 €All-time observed low: 119,22 €Unknown14/09/2026, 07.03Go to store
Showing 6 / 6 offers

The 30-day and all-time lows are ParhainHinta.fi observations for that merchant. They are not, by themselves, the merchant's statutory reference price for discount advertising.

Specifications

10G support
No
AC input frequency
50 - 60 Hz
AC input voltage
100 - 240 V
Authentication type
RADIUS, TACACS+
Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Cables included
AC
Certification
EMC ■ CE, FCC, C-Tick, Class A (GS1900-24/24EP/24HPv2/48/ 48HPv2) ■ CE, FCC, C-Tick, Class B (GS1900-8/8HP/10HP/16/24E) ■ BSMI CNS13438 • Safety ■ LVD EN60950-1 ■ BSMI CNS14336-1 ■ CB IEC60950-1 (GS1900-8HP/10HP/16/24E/24) • RoHS compliant
Depth
162 mm
DHCP features
DHCP client
Ethernet LAN data rates
10,100,1000 Mbit/s
Flow control support
Yes
Form factor
1U
Forwarding rate
35.7 Mpps
Full duplex
Yes
Harmonized System (HS) code
85176990
Heat dissipation
51.49 BTU/h
Height
42 mm
IGMP snooping
Yes
Installed SFP modules quantity
0
Installed SFP+ modules quantity
0
Jumbo frames
9000
Jumbo frames support
Yes
LED indicators
Yes
Link aggregation
Yes
MAC address auto-learning supported
Yes
MAC address filtering
Yes
MAC address table
8000 entries
Mallinumero
GS190024EEU0103F
Mean time between failures (MTBF)
804.714 h
MIB support
RFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9),RFC 1215 generic traps, RFC 1493 bridge, Zyxel private common MIB
Networking standards
IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Operating relative humidity (H-H)
10 - 95%
Operating temperature (T-T)
0 - 50 °C
Package depth
223 mm
Package height
71 mm
Package type
Box
Package weight
2.05 kg
Package width
325 mm
Packet buffer memory
0.525 MB
Password protection
Yes
Port mirroring
Yes
Power connector
AC-in jack
Power consumption (max)
15.1 W
Power over Ethernet (PoE)
No
Power source
AC
Power supply included
Yes
Product colour
Black
Quality of Service (QoS) support
Yes
Rack mount kit
Yes
Rack mounting
Yes
Reset button
Yes
Security algorithms
802.1x RADIUS
Spanning tree protocol
Yes
SSH/SSL support
Yes
Stackable
Yes
Static port security
Yes
Storage relative humidity (H-H)
10 - 95%
Storage temperature (T-T)
-40 - 70 °C
Store-and-forward
Yes
Switch layer
L2
Switch type
Managed
Switching capacity
48 Gbit/s
System event log
Yes
Virtual LAN features
Stacked VLAN, VLAN mapping
VLAN support
Yes
Wall mountable
Yes
Web-based management
Yes
Weight
1.56 kg
Width
267 mm
EAN / GTIN
4718937621132

Similar products